• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Audi RS3 Forum and Audi RS3 community dedicated to Audi RS3 owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Audi RS3 Forum today!

S3 whirl noise

Messages
5
Reactions
0
#1
Not sure if this has been posted before so sorry if have.

I have a 2009 s3 and been having noise come from rear. Had the diff oil changed no gremlins in oil had the Hadex oil changed to again all good. Just wondering if it could be the swagg joint as I had this inspected and is a tear in rubber. This noise is really noticeable at 40mph and around 75mph. Don’t think it’s the wheel bearings as the noise doesn’t get louder around curves etc.
 
Messages
206
Reactions
0
#2
It could be, whenever there is a tear in the rubber all the grease inside is going to leak.
 
OP
G
Messages
5
Reactions
0
Thread Starter #3
Sorry but it’s a thick rubber seal that goes inbetween the prop shaft and the rear diff. It’s there to takeaway away vibration. So being a tear I was wondering if this could be the source?
 

RS3Fan

Administrator
Staff member
Messages
34
Reactions
0
#4
Sorry but it’s a thick rubber seal that goes inbetween the prop shaft and the rear diff. It’s there to takeaway away vibration. So being a tear I was wondering if this could be the source?
I don't think that will cause the vibration if it's not a moving part. However it wouldn't hurt to replace any torn seals.
 
OP
G

Gixxer1186

New member
Messages
5
Reactions
0
Thread Starter #5
Of course it’s a moving part, It’s joined to a prop shaft!!
 

RS3Fan

Administrator
Staff member
Messages
34
Reactions
0
#6
Of course it’s a moving part, It’s joined to a prop shaft!!
Wait are you referring to the rubber coupler that kind of looks like this? I thought you were referring to some seal.
coupler.jpg
 
OP
G

Gixxer1186

New member
Messages
5
Reactions
0
Thread Starter #7
That’s it or referred to a ‘Swagg joint’ if deficient can cause noise apparently just wondering if anyone else had same problem.
 

Similar threads

New Audi RS3 Posts



Top