got my low coolant level light again. why?

#1
so i got my engine coolant light come on tonight. it did happen much earlier when i owned the car. its been a long time now since it happened. the first time it happened the dealership said its because the whole coolant system needs to be burped and this is the way the system releases the air trapped inside.

when that originally happened i didnt believe it but went with it as its not an engine i have worked on before. i work on japanese engines in the past. on japanese engines, it usually a sign of a bad head gasket and we can normally smell the coolant in the engine bay. well i can smell it since day one in the audi. i still smell it now. i have been able to smell coolant burning off for a while now. so ill need to bring it in again to see what they say. i would like to see it get pressure tested and have a compression test done as well.


so has anyone else experience this yet? once or even twice like me?
 
#2
Tell them to replace the water pump and thermostat. Problem solved.
 
#3
so i got my engine coolant light come on tonight. it did happen much earlier when i owned the car. its been a long time now since it happened. the first time it happened the dealership said its because the whole coolant system needs to be burped and this is the way the system releases the air trapped inside.

when that originally happened i didnt believe it but went with it as its not an engine i have worked on before. i work on japanese engines in the past. on japanese engines, it usually a sign of a bad head gasket and we can normally smell the coolant in the engine bay. well i can smell it since day one in the audi. i still smell it now. i have been able to smell coolant burning off for a while now. so ill need to bring it in again to see what they say. i would like to see it get pressure tested and have a compression test done as well.


so has anyone else experience this yet? once or even twice like me?
I know I'm new here but my job means I see this alot across the VAG range, not just on A3's/S3's.

Either your waterpump is leaking OR your thermostat housing is leaking. It's quite a common issue.

If you get the engine cooling system pressure tested when static on a warmed up engine, look for coolant trace at the bottom of the timing case (waterpump leak). Is very easy to see on Audi's as the coolant should be a flouresant pink dye.
 
#4
got the car done under warranty finally. they found a leak on the thermo housing.
 
#5
i can still smell coolant tho. ill give it a bit longer.
 


Top